Update
We are continuing to investigate this issue.
Posted Mar 10, 2023 - 15:08 CET
Investigating
We are currently investigating this issue.
Posted Mar 10, 2023 - 14:53 CET
This incident affects: Appen "apoteket" - Android (Login) and Appen "apoteket" - iOS (Login).